UbuntuInstall

From GNU Radio
Jump to: navigation, search

Building GNU Radio on Ubuntu Linux

This page is for reference for older Ubuntu systems. It describes prerequisites and dependencies.

GNU Radio works well on all Ubuntu versions from 10.04 upward. It is also possible to install GNU Radio on older releases of Ubuntu (see below). However, we may not be able to provide sufficient support for legacy OS.

Install the Prerequisites

The following packages are required for compiling various parts of GNU Radio on Ubuntu. These packages can be installed via your favourite package manager (e.g. Synaptic) or using the command lines given in the Install_Dependencies section.

  • Development Tools (need for compilation)
    • g++
    • git
    • make
    • cmake
    • sdcc (from "universe")
    • guile
    • ccache (not required, but recommended if you compile frequently)
  • Libraries (need for runtime and for compilation)
    • python-dev
    • SWIG
    • FFTW 3.X (libfftw3-dev)
    • cppunit (libcppunit-dev)
    • Boost 1.35 (or later, but not 1.46, 1.47 or 1.52)
    • GSL GNU Scientific Library (libgsl0-dev)
    • libusb and libusb-dev
    • ALSA (alsa-base, libasound2 and libasound2-dev)
  • GNU Radio Companion
    • for the GNU Radio Companion (GRC) you need to install python-numpy, python-cheetah and python-lxml
  • WX GUI
    • for the WX GUI components you need to install python-wxgtk2.8 and python-numpy
    • Note: the WX GUI has been deprecated in release 3.8
  • QT GUI
    • for the QT GUI components you need to install PyQT4, PyQwt5 for Qt4, QT-OpenGL, Fontconfig, Xrender and Xinput (python-qt4, python-qwt5-qt4, libqt4-opengl-dev, libqwt5-qt4-dev, libfontconfig1-dev, libxrender-dev, libxi-dev).
  • Video-SDL
    • for Video-SDL you need to install the Simple DirectMedia Layer development libraries (libsdl1.2-dev)
  • Polyphase Filter Bank examples
    • for the examples in gnuradio-examples/python/pfb to work you need to install python-scipy, python-matplotlib, and python-tk
  • Other useful packages
    • doxygen (for creating documentation from source code)
    • octave (from "universe")

Install Dependencies

The following command line scripts will install all the required dependencies. Before running them you should ensure that the Universe repository is enabled in "Software Sources".

To execute the script, copy and paste the relevant command line into a terminal.

Note: Mint 19.2 is based on Ubuntu 18.04. Mint 19.2 Cinnamon desktop installs gnome-terminal which may have to be uninstalled for non-gui flowgraphs to run properly. Mint 19.2 Mate does not install gnome-terminal by default.

Bionic Beaver (18.04)

GNU Radio version 3.8.x with Python 3 support:

sudo apt install git cmake g++ libboost-all-dev libgmp-dev swig python3-numpy \
python3-mako python3-sphinx python3-lxml doxygen libfftw3-dev libcomedi-dev \
libsdl1.2-dev libgsl-dev libqwt-qt5-dev libqt5opengl5-dev python3-pyqt5 \
liblog4cpp5-dev libzmq3-dev python3-yaml python3-click python3-click-plugins \
python3-zmq 

GNU Radio version 3.7.x:

sudo apt install cmake git g++ libboost-all-dev python-dev python-mako \
python-numpy python-wxgtk3.0 python-sphinx python-cheetah swig libzmq3-dev \
libfftw3-dev libgsl-dev libcppunit-dev doxygen libcomedi-dev libqt4-opengl-dev \
python-qt4 libqwt-dev libsdl1.2-dev libusb-1.0-0-dev python-gtk2 python-lxml \
pkg-config python-sip-dev 

Xenial Xerus (16.04)

Building GNU Radio 3.8.x is difficult on Ubuntu 16.04 due to various dependency issues (especially due to CMake and Python versions). Please consider using GNU Radio 3.7.x instead.

For GNU Radio 3.7.x:

sudo apt-get -y install git-core cmake g++ python-dev swig \
pkg-config libfftw3-dev libboost-all-dev libcppunit-dev libgsl0-dev \
libusb-dev libsdl1.2-dev python-wxgtk3.0 python-numpy \
python-cheetah python-lxml doxygen libxi-dev python-sip \
libqt4-opengl-dev libqwt-dev libfontconfig1-dev libxrender-dev \
python-sip python-sip-dev python-qt4 python-sphinx libusb-1.0-0-dev \
libcomedi-dev libzmq-dev 

Trusty Tahr (14.04)

sudo apt-get -y install git-core cmake g++ python-dev swig \
pkg-config libfftw3-dev libboost1.55-all-dev libcppunit-dev libgsl0-dev \
libusb-dev libsdl1.2-dev python-wxgtk2.8 python-numpy \
python-cheetah python-lxml doxygen libxi-dev python-sip \
libqt4-opengl-dev libqwt-dev libfontconfig1-dev libxrender-dev \
python-sip python-sip-dev

Then set the following environmental variable to use PyQT:

export PYTHONPATH=/opt/qt/lib/python2.7/dist-package

Saucy Salamander (13.10)

Saucy Salamander has a particular problem with PyQT and PyQWT. First, apt-get the following packages to get start. We will then manually build and install PyQT and PyQWT to get around the issue.

sudo apt-get -y install git-core cmake g++ python-dev swig \
pkg-config libfftw3-dev libboost1.53-all-dev libcppunit-dev libgsl0-dev \
libusb-dev libsdl1.2-dev python-wxgtk2.8 python-numpy \
python-cheetah python-lxml doxygen libxi-dev python-sip \
libqt4-opengl-dev libqwt-dev libfontconfig1-dev libxrender-dev \
libgruel3.6.1

If you have PyQWT installed already, remove it:
$ sudo apt-get remove python-qwt5-qt4

Make sure SIP is installed:
$ sudo apt-get install python-sip python-sip-dev

We'll set up a separate directory to install into to make it keep it nicely separated from anything else (in case Ubuntu fixes this problem).
$ sudo mkdir /opt/qt

First, set up your environment

Edit ./bashrc by adding or amending the following variables:

export PATH=/opt/qt/bin:$PATH
export LD_LIBRARY_PATH=/opt/qt/lib:/usr/local/lib:$LD_LIBRARY_PATH
export PYTHONPATH=/opt/qt/lib/python2.7/dist-packages:$PYTHONPATH
export PKG_CONFIG_PATH=/opt/qt/lib/pkgconfig:$PKG_CONFIG_PATH

Either restart the terminal or reset your environment:
$ source ~/.bashrc

Download and install PyQt version 4.10.3
http://www.riverbankcomputing.com/software/pyqt/download

   $ tar xzf PyQt-x11-gpl-4.10.3.tar.gz
   $ cd PyQt-x11-gpl-4.10.3
   $ python configure.py -b /opt/qt/bin -d /opt/qt/lib/python2.7/dist-packages -v /opt/qt/share/sip
   $ make
   $ sudo make install

Download and install PyQWT version 5.2.0
http://pyqwt.sourceforge.net/download.html

   $ tar xzf PyQwt-5.2.0.tar.gz
   $ cd PyQwt-5.2.0/configure
   $ ./configure.py -Q ../qwt-5.2 --module-install-path=/opt/qt/lib/python2.7/dist-packages/PyQt4/Qwt5
   $ make
   $ sudo make install

If you've already built GNU Radio, first delete CMakeCache.txt in the top build directory. You should then only have to 'make clean' in gr-qtgui.

Run cmake and make like you would normally. With the environmental variables pointing to the new PyQT and PyQWT versions we've installed all gr-qtui displays and widgets should work properly now.

Raring Ringtail (13.04)

Note: At release, Ubuntu defaults the 'libboost-all-dev' package to libboost-*.49, which is incompatible with GNURadio. Thus, until the Ubuntu default Boost install catches up, you must manually specify 'libboost1.53-all-dev'.

sudo apt-get -y install git-core autoconf automake  libtool g++ python-dev swig \
pkg-config libfftw3-dev libboost1.53-all-dev libcppunit-dev libgsl0-dev \
libusb-dev sdcc libsdl1.2-dev python-wxgtk2.8 python-numpy \
python-cheetah python-lxml doxygen python-qt4 python-qwt5-qt4 libxi-dev \
libqt4-opengl-dev libqwt5-qt4-dev libfontconfig1-dev libxrender-dev qt4-default

Precise Pangolin (12.04)

sudo apt-get -y install git-core autoconf automake  libtool g++ python-dev swig \
pkg-config libboost1.48-all-dev libfftw3-dev libcppunit-dev libgsl0-dev \
libusb-dev sdcc libsdl1.2-dev python-wxgtk2.8 python-numpy \
python-cheetah python-lxml doxygen python-qt4 python-qwt5-qt4 libxi-dev \
libqt4-opengl-dev libqwt5-qt4-dev libfontconfig1-dev libxrender-dev 

Natty Narwhal (11.04)

sudo apt-get -y install git-core autoconf automake  libtool g++ python-dev swig \
pkg-config libboost-all-dev libfftw3-dev libcppunit-dev libgsl0-dev \
libusb-dev sdcc libsdl1.2-dev python-wxgtk2.8 python-numpy \
python-cheetah python-lxml doxygen python-qt4 python-qwt5-qt4 libxi-dev \
libqt4-opengl-dev libqwt5-qt4-dev libfontconfig1-dev libxrender-dev 

Maverick (10.10)

sudo apt-get -y install libfontconfig1-dev libxrender-dev libpulse-dev \
swig g++ automake autoconf libtool python-dev libfftw3-dev \
libcppunit-dev libboost-all-dev libusb-dev fort77 sdcc sdcc-libraries \
libsdl1.2-dev python-wxgtk2.8 git guile-1.8-dev \
libqt4-dev python-numpy ccache python-opengl libgsl0-dev \
python-cheetah python-lxml doxygen qt4-dev-tools \
libqwt5-qt4-dev libqwtplot3d-qt4-dev pyqt4-dev-tools python-qwt5-qt4

Lucid (10.04)

sudo apt-get -y install libfontconfig1-dev libxrender-dev libpulse-dev \
swig g++ automake autoconf libtool python-dev libfftw3-dev \
libcppunit-dev libboost-all-dev libusb-dev fort77 sdcc sdcc-libraries \
libsdl1.2-dev python-wxgtk2.8 git-core guile-1.8-dev \
libqt4-dev python-numpy ccache python-opengl libgsl0-dev \
python-cheetah python-lxml doxygen qt4-dev-tools \
libqwt5-qt4-dev libqwtplot3d-qt4-dev pyqt4-dev-tools python-qwt5-qt4

Installing GNU Radio

Click here to show install instructions.

Configuring USRP support

This section is only relevant if you have a USRP1 that you want to use with GNU Radio. You may already have done this if you have installed UHD .

Ubuntu uses udev for handling hotplug devices, and does not by default provide non-root access to the USRP. The following script is taken from directions, and sets up groups to handle USRP via USB, either live or hot-plug

sudo addgroup usrp
sudo usermod -G usrp -a 
echo 'ACTION=="add", BUS=="usb", SYSFS{idVendor}=="fffe", SYSFS{idProduct}=="0002", GROUP:="usrp", MODE:="0660"' > tmpfile
sudo chown root.root tmpfile
sudo mv tmpfile /etc/udev/rules.d/10-usrp.rules

At this point, Ubuntu is configured to know what to do if/when it detects the USRP on the USB, except that "udev" needs to reload the rules to include the newly created one. The following might work, but if it doesn't then rebooting the computer will.

sudo udevadm control --reload-rules

or

sudo /etc/init.d/udev stop
sudo /etc/init.d/udev start

or

sudo killall -HUP udevd

You can check if the USRP is being recognized, by examining /dev/bus/usb after plugging in a USRP. Using the command:

ls -lR /dev/bus/usb | grep usrp

should result in one or more lines (one for each USRP) reading something like:

crw-rw---- 1 root usrp 189, 514 Mar 24 09:46 003

Each device file will be listed with group 'usrp' and mode 'crw-rw----'.

Once you've verified that the USRP is available to Ubuntu, now it is time to verify that GNU Radio works with the USRP. While "usrp_benchmark_usb" might not return a full 32 MB/s of throughput, the script should at least run properly; if not, either GNU Radio didn't make correctly or the USRP isn't accessible. From the "gnuradio" directory, verify that all of the following work:

  • Python interface to the USRP; provides a rough estimate of the maximum throughput (quantized to a power of 2) between the host computer and the USRP.
cd gnuradio-examples/python/usrp
./usrp_benchmark_usb.py
  • C++ interface to the USRP; provides a good estimate of the maximum throughput (non-quantized) between the host computer and the USRP.
cd usrp/host/apps
./test_usrp_standard_tx
./test_usrp_standard_rx

You are now ready to use GNU Radio and your USRP.

Building GNU Radio on Legacy Ubuntu

  • This page describes how to build and install GNU Radio from source on releases of Ubuntu Linux that are no longer supported by Canonical (9.10 or earlier). We strongly recommend using a newer version of Ubuntu.

Installation Options

This page provides information and scripts to compile and install GNU Radio and its required background applications, libraries, and includes on Ubuntu Linux 6.10 ("Edgy") or newer; they can probably be applied to some previous versions, though that hasn't been tested.

You might not be able to install the newest GNU Radio version unless you backport some of the depencies!

Install Scripts

The following are scripts to take most users through a GNU Radio install on a typical Ubuntu install, with the hope that it provides enough guidance such that you can get GNU Radio up and running on your Ubuntu box.

  • This section is for Edgy or previous only (no changes are needed on Feisty or newer, except possibly to disable the CDROM entry):

Manually uncomment all repositories to include "universe" and "multiverse" either via direct editing

  sudo  /etc/apt/sources.list

or via the provided GUI: System > Administration> Software Sources. Then enter the admin password for access. On the "Ubuntu" tab, make sure all of "main restricted universe multiverse" are checked and the rest unchecked (or deal with those are you deem correct for your setup). Click "Close", then "Reload" to update the package list.

The uncommented lines of the file "/etc/apt/sources.list" should read something like (DIST is a string with your particular distribution: edgy, feisty, gusty, etc):

deb http://us.archive.ubuntu.com/ubuntu/ DIST main restricted universe multiverse
deb http://us.archive.ubuntu.com/ubuntu/ DIST-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ DIST-security main restricted universe multiverse

Update the local dpkg cache:

sudo apt-get update

Install required packages (some are likely already installed by Ubuntu by default; some are likely redundant with others; but these groups cover all of the required packages, except for in Edgy)

  • Karmic (9.10)
sudo apt-get -y install swig g++ automake autoconf libtool python-dev libfftw3-dev \
libcppunit-dev libboost1.38-dev libusb-dev fort77 sdcc sdcc-libraries \
libsdl1.2-dev python-wxgtk2.8 git-core guile-1.8-dev \
libqt4-dev python-numpy ccache python-opengl libgsl0-dev \
python-cheetah python-lxml doxygen qt4-dev-tools \
libqwt5-qt4-dev libqwtplot3d-qt4-dev pyqt4-dev-tools python-qwt5-qt4
  • Jaunty (9.04)

Package sdcc-nf needs to be installed (instead of sdcc)

sudo apt-get -y install swig g++ automake1.9 autoconf libtool python-dev fftw3-dev \
libcppunit-dev libboost1.35-dev sdcc-nf libusb-dev \
libsdl1.2-dev python-wxgtk2.8 git-core guile-1.8-dev \
libqt4-dev python-numpy ccache python-opengl libgsl0-dev \
python-cheetah python-lxml doxygen qt4-dev-tools \
libqwt5-qt4-dev libqwtplot3d-qt4-dev pyqt4-dev-tools python-qwt5-qt4

Note: If you are upgrading from an older install, you may have python-wxgtk2.6 installed.
Because python-wxgtk2.6 takes precedence over python-wxgtk2.8, it must be removed first: sudo apt-get remove python-wxgtk2.6

  • Intrepid (8.10)

Package sdcc-nf needs to be installed instead of sdcc

sudo apt-get -y install swig g++ automake1.9 autoconf libtool python-dev fftw3-dev \
libcppunit-dev libboost1.35-dev sdcc-nf libusb-dev \
libsdl1.2-dev python-wxgtk2.8 git-core guile-1.8-dev \
libqt4-dev python-numpy ccache python-opengl libgsl0-dev \
python-cheetah python-lxml doxygen qt4-dev-tools \
libqwt5-qt4-dev libqwtplot3d-qt4-dev  pyqt4-dev-tools python-qwt5-qt4
  • Hardy (8.04): Boost should be installed as explained in README.building-boost file
sudo apt-get -y install swig g++ automake1.9 libtool python-dev fftw3-dev \
libcppunit-dev sdcc libusb-dev libasound2-dev libsdl1.2-dev \
python-wxgtk2.8 subversion guile-1.8-dev libqt4-dev python-numpy-ext \
ccache python-opengl libgsl0-dev python-cheetah python-lxml doxygen \
libqwt5-qt4-dev libqwtplot3d-qt4-dev qt4-dev-tools pyqt4-dev-tools
  • Gutsy (7.10): Boost should be installed as explained in README.building-boost file. GSL is required Also
sudo apt-get -y install g++ automake libtool python-dev fftw3-dev \
libcppunit-dev sdcc libusb-dev libasound2-dev \
libsdl1.2-dev python-wxgtk2.8 subversion guile-1.8-dev libgsl0-dev \
libqt3-mt-dev python-numpy-ext swig ccache
  • Feisty (7.04): Boost should be installed as explained in README.building-boost file. GSL is required Also
sudo apt-get -y install g++ automake1.9 libtool python-dev fftw3-dev \
libcppunit-dev sdcc libusb-dev libasound2-dev \
libsdl1.2-dev python-wxgtk2.8 subversion guile-1.6-dev\
libqt3-mt-dev python-numpy-ext swig ccache
  • Edgy (6.10): It is strongly recommended that you use one of the newer releases above
sudo apt-get -y install g++ automake1.9 libtool python-dev fftw3-dev \
libcppunit-dev libboost-dev sdcc libusb-dev libasound2-dev \
libsdl1.2-dev python-wxgtk2.6 subversion guile-1.6-dev \
libqt3-mt-dev python-numpy-ext ccache

Note that above line for Edgy installs python-wxgtk-2.6. While this is good enough for older gnuradio releases, it is too old for recent gnuradio svn snapshots. If you want to build a recent svn snapshot of gnuradio you need wxgtk version 2.8 or later.
You can install more recent wxgtk versions from the wxwidgets debian and ubuntu repository.
See Installing latest wxgtk-2.8 packages on debian or Ubuntu

Install optional packages, if desired; some might already be installed from the previous command:

sudo apt-get -y install gkrellm wx-common libwxgtk2.8-dev alsa-base autoconf xorg-dev g77 gawk bison openssh-server emacs cvs usbview octave

For Edgy only: Get, Compile, and Install SWIG

wget http://prdownloads.sourceforge.net/swig/swig-1.3.33.tar.gz
tar zxf swig-1.3.33.tar.gz
cd swig-1.3.33
./configure
make
sudo make install
cd ..

Optional: Get, Compile, Install QWT 5.0.0 (or newer):

  • NOTE: You should not need to set the environment variables "QTDIR" or "QWT_CFLAGS", so leave them be (for now).
wget http://superb-east.dl.sourceforge.net/sourceforge/qwt/qwt-5.0.2.tar.bz2
tar jxf qwt-5.0.2.tar.bz2
cd qwt-5.0.2
  • Now edit qwtconfig.pri:

' Change the unix version of "INSTALLBASE" to "/usr/local" (was "/usr/local/qwt-5.0.2");

' Change "doc.path" to "$$INSTALLBASE/doc/qwt" (was "$$INSTALLBASE/doc");

' Save, exit.
The "doc" portion is in both HTML and man-style, but is all in /usr/local/doc/{html,man}. While this isn't the standard path, there doesn't seem to be an easy way to separate them and thus this is left as is. Then:

qmake
make
sudo make install
cd ..

Install Boost

For Ubuntu 8.04 and older, download and install Boost 1.35 or later as follows (see README.building-boost file):

1) Download the latest version of boost from boost.sourceforge.net (boost_1_37_0.tar.bz2 was the latest when this was written but GNU Radio works with newer versions as well).

2) unpack it somewhere and cd into the resulting directory

$ cd boost_1_37_0

3) Pick a prefix to install it into. For example use /opt/boost_1_37_0

$ BOOST_PREFIX=/opt/boost_1_37_0

4) Configure

$ ./configure --prefix=$BOOST_PREFIX --with-libraries=thread,date_time,program_options

5) Compile the package

$ make

6) Install the package

$ sudo make install

$ cd ..

Installing GNU Radio

Click here to show install instructions.

Broken libtool on Debian and Ubuntu

Because Debian and Ubuntu apply a poorly implemented "enhancement" to the upstream version of libtool,
they break the ability to test code and libraries prior to installing them. We think that testing before
installation is a good idea. To work around their damage, be sure to include
$PREFIX/lib (and $PREFIX/lib64 on 64-bit machines) in /etc/ld.so.conf.

If you don't include $PREFIX/lib in /etc/ld.so.conf, you will see errors during the linking phase
of the build. There are several places it shows up. The first one is often during the build of
mblocks. It's not an mblock problem. It's a Debian/Ubuntu problem.

Do this to work around this feature

1) Make a copy from the current ld.so.conf file and save it in a temp folder:

cp /etc/ld.so.conf /tmp/ld.so.conf

2) Add /usr/local/lib path to it :

echo /usr/local/lib >> /tmp/ld.so.conf

3) If you installed Boost (version 1_37_0 for example) manually, then add its library path to the file:

echo /opt/boost_1_37_0/lib >> /tmp/ld.so.conf

4) Delete the original ld.so.conf file and put the modified file instead:

sudo mv /tmp/ld.so.conf /etc/ld.so.conf

5) Do ldconfig:

sudo ldconfig