CppUnitInstallCygwin

From GNU Radio
Revision as of 01:01, 21 March 2017 by Devnulling (talk | contribs) (Fix formatting - html entities)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Building and Installing CppUnit on Cygwin

GNU Radio uses CppUnit for testing. Although users are not required to run the tests, the installation procedure requires that the code for testing be available.

Note: If you installed cppunit 1.9.14-1 using Cygwin setup, you should uninstall it (using Cygwin setup) before building cppunit 1.12.0.

(1) Download cppunit-1.12.0.tar.gz from https://sourceforge.net/project/showfiles.php?group_id=11795 to /usr/src (i.e., C:\cygwin\usr\src on a default Cygwin installation). Unpack with

$ cd /usr/src
$ tar zxf cppunit-1.12.0.tar.gz

(2) If your gcc is older than 3.4.4-2: Download the patch file cppunit_dll_string.patch from [attachment:#56:cppunit_dll_string.patch] (using the "Original Format" link at the bottom of the page) to /usr/src. Apply the patch with

$ cd /usr/src/cppunit-1.12.0
$ patch -p0 -i ../cppunit_dll_string.patch
$ aclocal -I config
$ autoconf

If your gcc-core and gcc-g++ are version 3.4.4-2 or newer (cygcheck -c gcc-g++) you can skip this step.

(3) Build and install with:

$ ./configure
$ make
$ make check
$ make install

CppUnit is installed under /usr/local/* by default.

Notes:

  • you can use a directory other than /usr/src if you prefer
  • to install CppUnit somewhere other than /usr/local use the --prefix= option on ./configure (but be sure that GNU Radio's ./configure can find it)
  • make check fails in cppunittestmain on Cygwin when compiled with versions of gcc older than 3.4.4-2, but CppUnit seems to work ok with GNU Radio
  • if you are really lazy you can use the cppunit 1.9.14-1 package installed by setup; make check of GNU Radio will fail, but who really needs testing anyway?
  • for more information on CppUnit see http://cppunit.sourceforge.net/cppunit-wiki