Difference between revisions of "NumpyInstall"

From GNU Radio
Jump to: navigation, search
(Imported from Redmine)
 
(Update formatting)
 
Line 1: Line 1:
 
= Installing Numpy =
 
= Installing Numpy =
  
On most systems, numpy is available as a pre-built package, but if needed it can be installed from source by<br />
+
On most systems, <code>numpy</code> is available as a pre-built package, but if needed it can be installed from source by<br />
downloading numpy-1.1.0.tar.gz from http://sourceforge.net/project/showfiles.php?group_id=1369 to /usr/src then:
+
downloading <code>numpy-1.1.0.tar.gz</code> from http://sourceforge.net/project/showfiles.php?group_id=1369 to <code>/usr/src</code> then:
  
 
<pre>cd /usr/src
 
<pre>cd /usr/src
Line 16: Line 16:
 
if that is what you need). Or you can be the first to try a newer version.
 
if that is what you need). Or you can be the first to try a newer version.
  
* for more information on NumPy see http://numpy.scipy.org/
+
* For more information on NumPy see http://numpy.scipy.org/

Latest revision as of 00:04, 21 March 2017

Installing Numpy

On most systems, numpy is available as a pre-built package, but if needed it can be installed from source by
downloading numpy-1.1.0.tar.gz from http://sourceforge.net/project/showfiles.php?group_id=1369 to /usr/src then:

cd /usr/src
tar zxf numpy-1.1.0.tar.gz
cd numpy-1.1.0
python setup.py install

If you get errors that say

Error: suffix or operands invalid for @fnstsw'

it is because you are using Cygwin binutils 20080523-1. You will need to either reinstall binutils 20060817-1 or make corrections to the Numpy source; see hints tips known problems and solutions for Windows.

On MinGW, download and run numpy-1.0.3.1.win32-py2.4.exe (or the python 2.5 version,
if that is what you need). Or you can be the first to try a newer version.