Porting Existing Flowgraphs to a Newer Version

From GNU Radio
Revision as of 02:10, 19 February 2021 by Duggabe (talk | contribs) (initial creation)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

This page describes issues involved in porting a flowgraph to a newer version of GNU Radio.

From 3.7 to 3.8

When a flowgraph which has been generated by version 3.7 is opened in GRC version 3.8, much of the conversion process is done automatically. However, there are certain things which must be updated by hand.

  • WX GUI blocks: Since the WX GUI blocks are deprecated in version 3.8, the user must find corresponding blocks in the QT GUIs.
  • If blocks have different names between versions 3.7 and 3.8, they must be replaced by hand.

From 3.8 to 3.9

  • firdes vs window
  • filters, waterfall, signal gen

From 3.9 to master

  • Embedded Python Block: If a flowgraph containing an Embedded Python Block is executed without regenerating it, there will be an error that the `<flowgraph-name>epy_block_0.py` file can not be found. This is due to the change in the naming convention between version 3.9 and master. The remedy is to regenerate the flowgraph.