Difference between revisions of "Testing with Ubuntu 20"

From GNU Radio
Jump to: navigation, search
Line 1: Line 1:
Instructions for installing 3.8.1.0-rc1 and the latest Ubuntu 20 daily build
+
=== Instructions for installing 3.8.1.0-rc1 and the latest Ubuntu 20 daily build: ===
  
# Download latest daily build of Ubuntu 20 - http://cdimage.ubuntu.com/daily-live/current/focal-desktop-amd64.iso
+
* Download latest daily build of Ubuntu 20 - http://cdimage.ubuntu.com/daily-live/current/focal-desktop-amd64.iso
# Install it on a VM or wherever
+
* Install it on a VM or wherever
# sudo apt install git cmake g++ libboost-all-dev libgmp-dev swig python3-numpy python3-mako python3-sphinx python3-lxml doxygen libfftw3-dev libsdl1.2-dev libgsl-dev libqwt-qt5-dev libqt5opengl5-dev python3-pyqt5 liblog4cpp5-dev libzmq3-dev python3-yaml python3-click python3-click-plugins python3-zmq python3-scipy
+
* sudo apt install git cmake g++ libboost-all-dev libgmp-dev swig python3-numpy python3-mako python3-sphinx python3-lxml doxygen libfftw3-dev libsdl1.2-dev libgsl-dev libqwt-qt5-dev libqt5opengl5-dev python3-pyqt5 liblog4cpp5-dev libzmq3-dev python3-yaml python3-click python3-click-plugins python3-zmq python3-scipy
# Open Ubuntu's "Software & Updates" screen > Developer Options tab > Check the box "Pre-released Updates"
+
* Open Ubuntu's "Software & Updates" screen > Developer Options tab > Check the box "Pre-released Updates"
# sudo apt-get update
+
* sudo apt-get update
# sudo apt-get install gnuradio
+
* sudo apt-get install gnuradio
# Make sure it installed 3.8.1
+
* Make sure it installed 3.8.1

Revision as of 17:46, 21 February 2020

Instructions for installing 3.8.1.0-rc1 and the latest Ubuntu 20 daily build:

  • Download latest daily build of Ubuntu 20 - http://cdimage.ubuntu.com/daily-live/current/focal-desktop-amd64.iso
  • Install it on a VM or wherever
  • sudo apt install git cmake g++ libboost-all-dev libgmp-dev swig python3-numpy python3-mako python3-sphinx python3-lxml doxygen libfftw3-dev libsdl1.2-dev libgsl-dev libqwt-qt5-dev libqt5opengl5-dev python3-pyqt5 liblog4cpp5-dev libzmq3-dev python3-yaml python3-click python3-click-plugins python3-zmq python3-scipy
  • Open Ubuntu's "Software & Updates" screen > Developer Options tab > Check the box "Pre-released Updates"
  • sudo apt-get update
  • sudo apt-get install gnuradio
  • Make sure it installed 3.8.1