Editing UbuntuInstall

Jump to: navigation, search

Warning: You are not logged in. Your IP address will be publicly visible if you make any edits. If you log in or create an account, your edits will be attributed to your username, along with other benefits.

The edit can be undone. Please check the comparison below to verify that this is what you want to do, and then save the changes below to finish undoing the edit.
Latest revision Your text
Line 1: Line 1:
<b>There's generally no need to build GNU Radio from source code unless you want to modify GNU Radio rather than just using it.</b> The recommended way to install GNU Radio on most platforms is using already compiled binary packages. Binary installation should be sufficient for most users, and certainly for anyone who is new to GNU Radio. However, if you have special requirements, or a binary package is not available for your system, you may need to install GNU Radio from source.
 
  
In short: on Ubuntu versions since 9.10, use:
+
'''This page doesn't apply to modern Ubuntu versions. Please install GNU Radio through `apt`; you can get current GNU Radio releases from our [https://launchpad.net/~gnuradio/+archive/ubuntu/gnuradio-releases PPA].'''
 +
 
 +
In short: on modern Ubuntus
  
 
<pre>
 
<pre>
Line 9: Line 10:
 
</pre>
 
</pre>
  
See our [https://launchpad.net/~gnuradio/+archive/ubuntu/gnuradio-releases PPA] page for more details.
+
There's generally no need to build GNU Radio from sources unless you want to modify GNU Radio rather than work with it. If you want to modify GNU Radio, chances are you want to work on a modern version of Ubuntu to begin with.
  
This page describes prerequisites and dependencies for building GNU Radio from source code.
+
= Building GNU Radio on Ubuntu Linux =
  
= Building GNU Radio on Ubuntu Linux =
+
This page is for reference for older Ubuntu systems. It describes prerequisites and dependencies.
  
GNU Radio works well on all Ubuntu versions from 10.04 upward. It is also possible to install GNU Radio on older releases of Ubuntu (see [[#Building_GNU_Radio_on_Legacy_Ubuntu]]). However, we may not be able to provide sufficient support for legacy OS.
+
GNU Radio works well on all Ubuntu versions from 10.04 upward. It is also possible to install GNU Radio on older releases of Ubuntu (see below). However, we may not be able to provide sufficient support for legacy OS.
  
 
== Install the Prerequisites ==
 
== Install the Prerequisites ==
  
The following packages are required for compiling various parts of GNU Radio on Ubuntu. These packages can be installed via your favorite package manager (e.g. apt-get) or using the command lines given in the [[#Install_Dependencies|Install Dependencies]] section below.
+
The following packages are required for compiling various parts of GNU Radio on Ubuntu. These packages can be installed via your favourite package manager (e.g. Synaptic) or using the command lines given in the [[UbuntuInstall#Install_Dependencies|Install_Dependencies]] section.
  
 
* Development Tools (need for compilation)
 
* Development Tools (need for compilation)
Line 62: Line 63:
 
== Install Dependencies ==
 
== Install Dependencies ==
  
<p>The following command line scripts will install all the required dependencies. Before running them, you should ensure that the "Main" and  "Universe" repositories are enabled in &quot;Software Sources&quot;. See https://help.ubuntu.com/community/Repositories/Ubuntu for a complete description.</p>
+
<p>The following command line scripts will install all the required dependencies. Before running them you should ensure that the Universe repository is enabled in &quot;Software Sources&quot;.</p>
  
 
To execute the script, copy and paste the relevant command line into a terminal.
 
To execute the script, copy and paste the relevant command line into a terminal.
  
=== Notes ===
+
Note: Mint 19.2 is based on Ubuntu 18.04.  Mint 19.2 Cinnamon desktop installs gnome-terminal which may have to be uninstalled for non-gui flowgraphs to run properly.  Mint 19.2 Mate does not install gnome-terminal by default.
  
* Mint 19.2 is based on Ubuntu 18.04.  Mint 19.2 Cinnamon desktop installs gnome-terminal which may have to be uninstalled for non-gui flowgraphs to run properly.  Mint 19.2 Mate does not install gnome-terminal by default.
+
=== Bionic Beaver (18.04) ===
 
 
=== Focal Fossa (20.04) ===
 
  
 
GNU Radio version 3.8.x with Python 3 support:
 
GNU Radio version 3.8.x with Python 3 support:
  
<pre>
+
<pre>sudo apt install git cmake g++ libboost-all-dev libgmp-dev swig python3-numpy \
sudo apt install git cmake g++ libboost-all-dev libgmp-dev swig python3-numpy \
+
python3-mako python3-sphinx python3-lxml doxygen libfftw3-dev libcomedi-dev \
python3-mako python3-sphinx python3-lxml doxygen libfftw3-dev \
 
 
libsdl1.2-dev libgsl-dev libqwt-qt5-dev libqt5opengl5-dev python3-pyqt5 \
 
libsdl1.2-dev libgsl-dev libqwt-qt5-dev libqt5opengl5-dev python3-pyqt5 \
 
liblog4cpp5-dev libzmq3-dev python3-yaml python3-click python3-click-plugins \
 
liblog4cpp5-dev libzmq3-dev python3-yaml python3-click python3-click-plugins \
python3-zmq python3-scipy python3-gi python3-gi-cairo gobject-introspection gir1.2-gtk-3.0
+
python3-zmq </pre>
</pre>
 
 
 
The development version of GNU Radio (3.9) additionally requires:
 
 
 
<pre>
 
sudo apt install pybind11-dev python3-matplotlib libsndfile1-dev
 
</pre>
 
 
 
=== Bionic Beaver (18.04) through Eoan Ermine (19.10) ===
 
 
 
GNU Radio version 3.8.x with Python 3 support:
 
 
 
<pre>
 
sudo apt install git cmake g++ libboost-all-dev libgmp-dev swig python3-numpy \
 
python3-mako python3-sphinx python3-lxml doxygen libfftw3-dev \
 
libsdl1.2-dev libgsl-dev libqwt-qt5-dev libqt5opengl5-dev python3-pyqt5 \
 
liblog4cpp5-dev libzmq3-dev python3-yaml python3-click python3-click-plugins \
 
python3-zmq python3-scipy
 
</pre>
 
  
 
GNU Radio version 3.7.x:
 
GNU Radio version 3.7.x:
Line 233: Line 212:
 
== Installing GNU Radio ==
 
== Installing GNU Radio ==
  
Click [[InstallingGR#From_Source|here]] to show install instructions.
+
Click [[InstallingGR#To_install_system_wide|here]] to show install instructions.
  
 
== Configuring USRP support ==
 
== Configuring USRP support ==
Line 438: Line 417:
 
mblocks. It's not an mblock problem. It's a Debian/Ubuntu problem.
 
mblocks. It's not an mblock problem. It's a Debian/Ubuntu problem.
  
Do this to work around this &quot;feature&quot;:
+
Do this to work around this [[feature]]
  
 
1) Make a copy from the current ld.so.conf file and save it in a temp folder:
 
1) Make a copy from the current ld.so.conf file and save it in a temp folder:

Please note that all contributions to GNU Radio are considered to be released under the Creative Commons Attribution-ShareAlike (see GNU Radio:Copyrights for details). If you do not want your writing to be edited mercilessly and redistributed at will, then do not submit it here.
You are also promising us that you wrote this yourself, or copied it from a public domain or similar free resource. Do not submit copyrighted work without permission!

To edit this page, please answer the question that appears below (more info):

Cancel | Editing help (opens in new window)